Sunday, April 7, 2013

I've Had it Up to HERE

My sincerest apologies for my lack of posting lately. I somehow upgraded my internet to Explorer 10 and it SUCKS STEGASAURUS BALLS!

Half the time, my top tool bar is missing. And when it appears, the bottom one disappears. Then, it will open one website fine one day, and the next, it won't.

9 times out of 10, I can't save photos on my desktop that I emailed to myself from my phone. And I just learned today that it doesn't want to save photos where I have put a watermark on them. Awesome. Then I get a white screen of death about every third website I visit.

Perhaps the most frustrating is that sometimes it won't even let me type in a text box to post a blog! Those few of you who have my personal blog have noticed my complete and total absence there... I no longer have the ability to type on the website.

It is the most fucking ridiculous thing ever. Microsoft - get your shit together!!!!!

So... until I figure out how to get another browser, my posts will be much more sporadic and I hate it. Stick with me please. Technology seriously hates me right now. Maybe I need to show it a little more cleavage or something.

Ideas???

2 comments:

kimhead said...

Download Mozilla Firefox or Chrome. I can't even remember the last time I used Explorer!

The Fischer Family said...

Hence the reason I left IE years ago and switched over to FireFox. It is awesome! I love it and NEVER have issues! Check it out! I will never use IE again! Oh, and Stegasaurus balls would be seriously large my friend! Just sayin'!!